HOW TO SPEED UP ANY DESKTOP OR LAPTOP COMPUTER

When you start using a new computer it's fast and may impresses you as a big
change from before. On the other hand you may be disappointed at the relatively
small increase in speed. Even if fast, over time your machine may get bogged down.
After a few months you may wonder if it is worth computing at all, considering
how long it takes to do anything.

The truth is by default when your computer arrives it has many services and
unneeded programs that can be turned off or deleted without harm. Also

with a machine that has slowed over time, many things can be done to improve
the speed. In fact, after a treatment like here's, you'll be amazed what a tiger
was under hood. If you were considering it, you may decide to postpone the
purchase of a new one. The various procedures and habits you can perform
and change are as follows

Make Sure You Have Enough Memory

Choose Start Button -> Start Menu ->
Settings -> Control Panel -> System -> General Tab

Before You Buy Computer Memory Upgrades, you can find out how much
you have by clicking on the System Icon in the Control Panel. The amount is
on the first tab that comes up, the General Tab.

With Windows 2000 or XP, you really should have at least 1 GB of memory
and 2 GB is a more comfortable amount. With Vista be sure to have 2 GB of
memory you'll be much happier.



Be Sure To Clean Up Your Desktop

Windows puts everything on your Desktop into memory, for rapid loading purposes.
If you have a lot of big files there, that means trouble. Apparently folders are not 1
oaded. Shortcuts apparently are loaded, but it stops there. The applications the
shortcuts point to are not loaded. Maybe downloaded exe files are though.

Make Sure You Have a Fast Enough CPU Chip

Only Windows XP and Vista, in the System Applet again, will show you how fast
your processor is. 1 GHz Processor is really the minimum these days. If you have
less than this, spare yourself some frustration and buy a cheap new computer

for $250-$400 from Dell, HP, Compaq, E-machines, or Gateway. You'll be
much happier.



Uninstall Those Unneeded Applications To Free Up Memory

One last suggestion of the about.com article that sounds useful, is to uninstall unneeded
programs. The reason for this is apparently the registry settings made by installed
programs can eventually slow down your machine. A smaller cleaner registry is
therefore useful. A registry cleaner might be a good tool to use too after removing

the unneeded programs. It will be discussed again below.

DO YOU KNOW THE TYPES OF RAM? ITS HERE

Get And Keep Your BIOS Fine Tuned

In the BIOS (or "Setup") stop floppy seek, stop memory check (Fast Boot), and
put the disk on best performance setting instead of silent if you have it.

For a faster boot up enter your Bios, by clicking the Delete, F2, or F12 key or
whatever flashes on the screen when you turn on the computer. Next choose boot
order, and remove all entries except the first one which you should set to your
hard drive. This will stop the most of the time useless seeking of a floppy

disk at boot time.

If you need to reinstall Windows or some other operation, you can always go back
and change this entry to floppy or CD. Also there should be a setting in your
BIOS to make the boot, quick.


http://www.computermemoryupgrade.net/types-of-computer-memory-common-uses.html

Patch Your Computer To Keep It Updated

Go to Windows update on the top of your start menu and download all the patches for
your operating system, whether they are optional or critical.

Better yet, go into the Control Panel, choose Automatic Updates, Choose Automatic
(your screen might look different with a different version of Windows). Make it
Every Day at a time when you are not using your computer (say 2 AM). Make

sure your PC's other major programs are up to date with Secunia: http://secunia.
com/vulnerability scanning/.

Generally if you have cable or DSL, despite the risk of infection, computers
should be kept on and attached to the Internet. This is to allow antivirus and
security patches downloading at off-peak hours.

Keep Your Antivirus Up to Date and Scan Your Disks

Bring your antivirus program up to date and regularly do a full virus scan of your
computer. Check your antivirus program as it will tell you when the last full scan
was done. You may be surprised to see it is not what you thought, but was

done months ago.

If you don't have an up to date antivirus program, and don't want to pay for a new
one, there are several high quality free ones available to the private consumer.
They are: AVG, Antivr, avast, PC Tools antivirus, Comodo antivirus and the
open source ClamAV.

Also look into a new different kind of antivirus program ThreatFire which you can use
to supplement your other antivirus. ThreatFire doesn't look for the fingerprints or
DNA of known viruses. Instead it looks for suspicious behavior like key logging.

Also try the no longer free WinHki Anti-Virus, which acts as a supplement to normal
Anti-virus program like above. WinHki calculates the checksums ( a mathematical
calculation extremely difficult to fool) of your files on initialization. After that,
whenever a virus changes a file it will be flagged by WinHki because the

checksum will change.



Make Sure Your Antivirus/Internet Security Programs Run at Night

If you are noticing slowness in your PC and you hear your hard drive churning,
it may be because the antivirus is doing a scan during the middle of the day.
Reschedule it for the night. Also check to make sure it updates at night. While
your at it, look in Windows update settings in your System app in the Control
Panel in XP or by itself as an app in the Control panel in Vista. Perhaps it is
updating during the day too instead of the default 3 AM. That could be a real
slower in performance.

COMPARE THE BEST ANTI-VIRUS PROGRAMS HERE

Make Sure You Have no Spyware

Run at least a couple different antispyware programs. Perhaps most people these
days are buying full computer suites to use with their computers, which should
include antispyware programs, but it doesn't hurt to independently run stand
alone ant-spyware programs.

The free ones are, SuperAntiSpyware (maybe the best of the free ones now),
Spybot, LavaSoft's Ad-Aware, Yahoo Toolbar with Anti-Spy, and "Bazooka
Adware and Spyware Scanner".

Note it's also a good idea to use the free spyware prevention tool, Spyware
Blaster.

The commercial anti-spyware programs SpySweeper, SpywareDoctor and
CA Anti-Spyware (formerly Pest Patrol) are excellent. They cost $30-40.


http://www.guard-privacy-and-online-security.com/best-antivirus-program.html

Stop Unneeded Startup Programs

New installation of software often adds unneeded startup entries in any of several
different hidden locations. These programs will start when Windows starts and
take up resources.

The best free program to deal with this problem, is in my opinion, Startup Inspector
for Windows. If you use this program, be sure to select the "Consult" Button in the
upper left of GUIL.

This will make the program search through its database of startup programs and tell
you whether the software is necessary or can be safely removed from the bootup
sequence. Windows Defender is Microsoft's similar program. It's standard in Vista
and can be reached through the Control Panel. Click on Tools -> Software
Explorer, to see all the programs that begin at startup.

Another good choice is Codestuff Starter. This free program has the additional
advantage of having a sort of Power Task Manager which will tell you all the programs
that are currently running and all their dll dependencies. Additionally there is a new
section on Services, so you can look through these semi-programs that are running

in the background and see if there are any you don't need. More on services

in a later step.

Unfortunately you will manually have to look up your entries in other resources to see
whether the software is necessary for normal functioning. You can also sometimes
get info about the manufacturer of the running program by double clicking on its
entry in the Startup list. The best database for checking whether programs are
necessary is http://www.castlecops.com/StartupList.html.

To get a real expert list of Start-Up programs running on your machine, including browser
helper objects try Hijack this, now owned by Trend Micro. HijackThis lists of starting
objects can be posted to newsgroups where experts for free, will examine them for
irregularities.


http://www.castlecops.com/StartupList.html.

Defragment Your Hard Drive Regularly

Vista now includes an automatic defragment system that is enabled by default. With
XP or Vista (if you want to set it off outside the schedule) defragment your hard
drive by choosing Start -> Programs -> Accessories -> System Tools -> Disk
Defragmenter.

This should be done every week if possible and can take several hour, so again do

it at night or while you are at work. There are some free disk defragmenter

scheduler solutions, so you can "set it and forget it." They are startdefrag, autodefrag
and Lexun Freeware Drivecare. There is also a Microsoft article that tells you how
to use Scheduler to schedule defragmentation.

Remove Those Unneeded Files

Hard disk begin to fragment files noticeably and slow down after passing the 50%
full mark. For this reason, it is said that the single most important investment one can
make to improve the performance of a PC is to purchase the largest hard drive possible.

This situation will change with the advent of solid state hard drives as the files don't
fragment meaningfully in these sort of devices. At any rate if you have a hard drive

and it's over 50% full, use a program like CCleaner or Microsoft's disk utility to get rid
of unneeded files.



Also uninstalling unneeded software can improve performance for disk space reasons

and because programs often install right click options which disappear after uninstallation.
This is valuable because menus are often built on the fly and take time to rebuild each
time you open them. With less options there's faster performance.

Move the Page File to Another Partition

The page file is your virtual memory. Windows uses your hard drive as a secondary
source of memory in addition to your RAM memory. If you move this file to another
partition then the one where Windows is installed this can increase performance.

You can change this setting here: Control Panel->System Applet->Advanced
Properties->Performance Settings Button->Advanced Tab->Virtual Memory Settings
Button->Click on the C drive and change the setting to no virtual memory and hit

the "set" button->move the selection to another partition and set it to 150% of the
amount of RAM memory you have in both the minimum and maximum amounts.
Then click the "set" button.

Stop File Indexing

By default, in order to speed file searches in XP and Vista, Windows indexes the
entire drive. However most people do not search very often and find that the
overhead that the process represents in terms of memory and CPU cycle

does not justify the short time lost looking for files that have not been indexed
once in awhile.

It is true that this indexing is only supposed to take place during times when the
machine is not in use, but the system doesn't work perfectly and makes for
continual noise from the hard drive through out the time the PC is on.

At any rate to stop indexing is a bit of an involved process.



To start it, right click on your C: drive in My Computer or Explorer and choose
"Properties". Simply uncheck the checkbox "Allow the Indexing Service index

this disk for fast file searching" -> In the next Window that comes up, choose the
radio button next to "apply changes to C:\, subfolders and files. That's the easy part.

Because it's applying the changes to all the folders, this process takes up a lot
resources and time. As a shortcut to all this you could stop the indexing service
in XP by typing type "net stop CiSvc" without the quotes. For a long time stop
of the Indexing Service you would need to disable it.

Type services.msc in the Run box -> right click on the Indexing Service -> choose
disabled from the Startup type drop down box. In Vista, do the same thing with
the command "net stop WSearch" and disabling the Windows Search Service.

A third way to do this in XP and VlIsta is to go to Add/Remove Programs inm the
Control Panel (Programs and Features in Vista) and choose Add/Remove Windows
Components (in Vista "Turn Windows features on and off"). There you'll find the
Indexing Service which you can uninstall. If I remember correctly with Vista, there is
some Indexing that goes on even if you have done all three of these things. This might
be related to Vista's Prefetch and Superfetch systems.

Turn Off Animations

In XP and Vista, some visual effects have been added to the basic Windows 2000
appearance. These can be removed to improve PC speed. You can do this here:
Control Panel->System Applet->Advanced System Settings (in Vista) or Advanced
tab (In XP)->Performance Settings Button->Visual Effects->Adjust for best
performance. You may want to restore the use of smooth edges for screen fonts
and the showing of thumbnails instead of icons (In Vista only).



Clean the Registry

Over time the registry gets clogged up with useless registry settings that slow a PC.
Freeware to fix this issue include PC Fixer, CCleaner and Toni Arts EasyCleaner
among others.

Stop Unneeded Services

Services are again programs that Windows starts up automatically at startup and
run in the background (some of them at least others are started when needed).
Many of these are not needed and stopping them can help speed up you considerably.

To get to services, click on the Start Menu and in the Run dialogue box add "services.
msc" and hit return. Now, consult one of the lists on the net, which list which services
are necessary and which are not.

Black Viper provides one (http://www.blackviper.com/WinXP/servicecfg.htm), another
one is ClanKiller's

(http://www.clankiller.com/technical/tweaks/winxp/servicestweaks.php).

Also look at a program called WinServices. If you download the mini setup of
version 2.1.4.0, and choose Tools->"Program Settings"->Columns Tab_>Select
Activate Recommendations->check "Suggested Settings" and "Safely disable",

the program will show which services you can disable. Use a little common sense here,
for instance Task Scheduler might be better left on. Check with the other sites.

Turn off fancy desktop backgrounds, and screensavers

Elaborate background pictures and fancy screensavers can take up an enormous
amount of RAM memory and Hard disk space. For instance with hibernation activated,
a file easily 1 GB in size is created in the root of the C: drive.



If you are low on hard disk space, this can be vital. These operations can be done by
right clicking on a blank part of your Desktop and choosing "Properties." Go to the
Desktop Tab and set the Background to "None." On the screensaver Tab, set the
Screensaver to "None."

To turn off the Hibernation feature in XP only: Right Click on your Desktop ->
choose Properties -> Click on the Screen Saver Tab -> Click on the Power Button
in the lower right corner -> Click on the Hibernate Tab -> Uncheck "Enable
hibernation". For Vista see this article in regards to hibernation: http://support.
microsoft.com/kb/929658.

LEARN ALL ABOUT READYBOOST RIGHT HERE

ReadyBoost for Vista Speeds Boot Times and Other Operations

With Vista, if you plug in USB or other flash memory, you will be given a choice to
use the device with machine as ReadyBoost agent. It's a little complicated and I
don't understand it, but, the PC uses the drive then for SuperFetch routines as
cache memory, whatever that means.

All you seem to have to know is that using USB memory as ReadyBoost can speed
boot times as well as other memory intensive activities that the PC would normally
use the hard drive virtual memory for. Your free memory can be 256 MB to 4

GB usable by the machine.

You must tell the machine to set aside this amount and you will not be able to use that
memory while the card is plugged in the machine. Apparently also the machine

learns during each boot up so the boot up times gradually get faster. A Wikipedia
article is here and at the end of the Live Links/Additional Resources list:
http://en.wikipedia.org/wiki/ReadyBoost. Note some flash memory is not fast

enough to serve as ReadyBoost material.


http://www.microsoft.com/windows/windows-vista/features/readyboost.aspx

Change Your PC use Habits

Things that can speed the Windows experience is to rely more heavily on keyboard
shortcuts. Print out a cheat sheet for yourself for reference. Two links are listed below.
Another thing to do is to use Windows Quick Launch Toolbar. You display this right
clicking on the Start Button -> choosing Properties -> Choosing the Toolbars tab ->
check the Quick Launch Toolbar display option box.

If you hold down the control button you can drag shortcuts from the Start Menu or
desktop and keep copies in their original locations. Another speed tip is when
surfing and downloading start many at the same time, you don't have to wait for
one download to finish before starting another.

Also you might try to download the free Opera Internet browser or Apple's Safari

for Windows. It is the fastest but will not display some of the pages IE and Firefox
can display. I use all three browsers about equally. Another thing to try is to set up
category folders in your Startup menu.

You can then drag the programs folders into the folders. This speed things because
it takes Windows some time to rebuild its menus each time you click on them. You
can get to the Start menu folders by right clicking on the Start Button and choosing
"Explore".

There is a complication that not all the Start Menus are stored under your user name.
However if you work at it you can categorize most of your folders by dragging them
around and placing them in new folders. You can also right click on the folder and
choose cut, then paste them in your new folders. Additionally if your right click on the
Start Menu Folder and it does not give you the cut option, it's probably installed in
the Default or All user folders. Choose the "Open all users" option instead to
manipulate those folders



Have Your PC health Assessed for Free at PC Pitstop

PC Pitstop will give you a wealth of information about whether you have enough disk
space, how fragmented your drives, whether you have enough memory and many
other things discussed below. This is an unbelievable free service and can be done
anonymously.

VISIT PC PITSTOP.COM BY CLICKING HERE



http://www.pcpitstop.com/

